Digieffects v2.5 - Damage and Delirium

December 28, 2011, 09:29 AM

http://provideocoalition.com/index.php/editingpost...

Digieffects has updated and optimized their plugin effects to be Adobe CS5/64-bit compatible and have added some great new tools to their suite of tools! Both Damage v2.5 and Delirium v2.5 are fully compatible with the latest versions of After Effects, Premiere Pro, FCP and Edius. Even better news, this is a free upgrade for registered v2.0 owners!

Log in to comment.

© 2007-2021 www.aotg.com Ver. 3.0 All Content created and posted by Art of the Guillotine users Art of the Guillotine graphics, logos, designs, page headers, button icons, scripts, and other service names are the trademarks of Art of the Guillotine Inc. Use of this material outside of this site is strictly prohibited.