Media Composer 4.0.4 gets Snow Leopard Support

November 24, 2009, 04:24 AM

http://lfhd.net/2009/11/23/avid-media-composer-4-0...

Earlier today Avid release Media Composer version 4.0.4. This version adds support for MacOS 10.6, or Snow Leopard. GREAT news for all those people who bought new Macs that only come with Snow Leopard installed. If you have Leopard, 10.5, then you can stick with what you have (MC 4.0.4 is compatible with Leopard, version 10.5.8.).

Log in to comment.

© 2007-2022 www.aotg.com Ver. 3.0 All Content created and posted by Art of the Guillotine users Art of the Guillotine graphics, logos, designs, page headers, button icons, scripts, and other service names are the trademarks of Art of the Guillotine Inc. Use of this material outside of this site is strictly prohibited.